TiVo Community Forum

TiVo Community Forum Archive 2
Covering threads with a last post date between
July 1, 2004 and December 31, 2005.
THIS IS A READ ONLY SITE
 


 

SEARCH  |  ARCHIVE 1 MAIN SITE

 
Forum Jump
 
Thread Tools Search this Thread Display Modes
Old 11-21-2005, 02:07 AM   #1 (Print)
mad6c
Registered User
 
Join Date: Nov 2003
Posts: 11
Drive Replacement in Phillips DSR7000

The Hard-Drive in my DTivo Phillips DSR7000 seemed to be on it's way out, recordings were starting to freeze. Before a complete failure I decided to image the drive to a new hard drive using MFS Tools. I used the command:

mfsbackup -Tao - /dev/hda | mfsrestore -s 127 -xzpi - /dev/hdb

After a few hours, the processed failed with the following error:

Restore failed: internal error 3.s at 45.48%

The orginial drive would no longer boot. I tried doing just an OS copy with the following command:

mfsbackup -f 9999 -6so - /dev/hda | mfsrestore -s 127 -r 4 -xzpi - /dev/hdb

This failed with a seek error before it even started. I figure I was SOL now, so I popped the new drive in the Dtivo. I was just curious if it would boot with a partially copied image. To my suprise it booted and appears to be working now. Most of the recording didn't work so I did a Clear and Erase. This took about 2.5hrs. The original drive was 40GB and the new is 80GB. The Tivo only sees 40GB, I guess the expand never happened during the original mfsbackup/mfsrestore. One wierd thing is the background on the main DirecTV Central screen is black but everything else seems to work properly. Any ideas on why this would be?

I'm still debating if I want to do an mfsadd -x or just count my blessings that it is working at all.

My parents have a DTivo as well but a different Phillips model. Can I copy an image from it to mine or do the models need to match exactly?

Any help or suggestions that anyone can offer would be appreciated I'm new at this.

Thanks,
Mike

Last edited by mad6c : 11-21-2005 at 09:22 AM.
mad6c is offline Report Bad Post Report Post
Old 11-22-2005, 07:49 AM   #2 (Print)
mad6c
Registered User
 
Join Date: Nov 2003
Posts: 11
Another strange thing I noticed is there are no channel logos. It used to have them. Is this something the box will download over time?

Mike
mad6c is offline Report Bad Post Report Post
Old 11-22-2005, 01:18 PM   #3 (Print)
classicsat
Astute User
 
Join Date: Feb 2004
Location: Ontario Canada.
Posts: 7,949
Try a dd_rescue copy, then expand.

__________________
TCD240080, 160 GB HDD.
FC3 Linux box running Galleon.
TiVo desktop on XP machine.
classicsat is offline Report Bad Post Report Post
Old 11-22-2005, 05:53 PM   #4 (Print)
mad6c
Registered User
 
Join Date: Nov 2003
Posts: 11
If I have an old Image with the 3.1 software. Will the unit upgrade itself to the new 6.2 software DirecTV is running?

Mike
mad6c is offline Report Bad Post Report Post
Old 11-22-2005, 09:13 PM   #5 (Print)
litzdog911
TechKnow Guide
 
litzdog911's Avatar
 
Join Date: Oct 2002
Location: Mill Creek, Washington
Posts: 7,860
Send a message via AIM to litzdog911
Quote:
Originally Posted by mad6c
If I have an old Image with the 3.1 software. Will the unit upgrade itself to the new 6.2 software DirecTV is running?

Mike


Yes. Your DVR should download and update to 6.2 within the first couple of days after you set it up.

__________________
Sony SAT-T60 120GB (v3.1.0c2)
HR10-250 HiDef 250GB (v3.1.5f)
R10 80GB (v6.1-01)
Sony SAT-A4, B4 Receivers
Sony KV-40XBR800 HDTV
litzdog911 is offline Report Bad Post Report Post
Old 12-27-2005, 10:00 PM   #6 (Print)
mad6c
Registered User
 
Join Date: Nov 2003
Posts: 11
Loaded the older downloaded image and the device updated itself to the current software release after a few days.

Thanks everyone for your help.

Mike
mad6c is offline Report Bad Post Report Post
 
Forum Jump
Thread Tools

Go Back  TiVo Community Archive2 > Underground Playground > TiVo Upgrade Center

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:13 AM.


Powered by: vBulletin Version 3.0.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
(C)opyright - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not affiliated with TiVo Inc.


Spider History Index