TiVo Community Forum

TiVo Community Forum Archive 2
Covering threads with a last post date between
July 1, 2004 and December 31, 2005.
THIS IS A READ ONLY SITE
 


 

SEARCH  |  ARCHIVE 1 MAIN SITE

 
Forum Jump
 
Thread Tools Search this Thread Display Modes
Old 12-16-2005, 01:57 PM   #1 (Print)
Heuer
Registered User
 
Join Date: Mar 2004
Location: Nottinghamshire
Posts: 270
Running out of ideas!

TiVo started freezing on me so I installed a new HD. Old HD had an LBA error and has been RMA'd to Samsung.

Having installed the new 200Gb HD I found TiVo deadly slow to respond to the remote and when I forced a daily call over Cachecard it just rebooted. Also found if I gave too many remote signals it rebooted. Telnet is slow to respond but TiVoweb seems fine. Swapped out the PSU thinking this was the problem, tried a second disk image (again under LBA48/Copykern) but the problem remains.

Kernel log shows:

Jan 1 00:03:49 (none) kernel: Starting rc.sysinit
Jan 1 00:03:49 (none) kernel: Releasing /initrd and clearing ramdisk, if they exist
Jan 1 00:03:49 (none) kernel: warning: can't open /var/mtab: No such file or directory
Jan 1 00:03:49 (none) kernel: umount: /initrd: not mounted
Jan 1 00:03:49 (none) kernel: Activating swap partitions
Jan 1 00:03:49 (none) kernel: Unable to find swap-space signature
Jan 1 00:03:49 (none) kernel: swapon: /dev/hda8: Invalid argument
Jan 1 00:03:49 (none) kernel: Loading i2c driver
Jan 1 00:03:49 (none) kernel: Box setup for PAL mode
Jan 1 00:03:49 (none) kernel: Loading FPGA driver
Jan 1 00:03:49 (none) kernel: fpga driver configured in PAL mode.
Jan 1 00:03:49 (none) kernel: fpga module running SAA7118 video encoder
Jan 1 00:03:49 (none) kernel: Msp: MajorRevCode Version 0x4
Jan 1 00:03:49 (none) kernel: Msp: ROM Version 0xa25
Jan 1 00:03:49 (none) kernel: Msp: ProductCode = 0xa
Jan 1 00:03:49 (none) kernel: Msp: MSP3410
Jan 1 00:03:49 (none) kernel: MSP34X0D
Jan 1 00:03:49 (none) kernel: memstart = 0x80154000 : size = 0x120000
Jan 1 00:03:49 (none) kernel: Standin 0: addr 0x80158000, len 0x11c000
Jan 1 00:03:49 (none) kernel: Checking for Kickstart panic signal
Jan 1 00:03:49 (none) kernel: No panic situation detected
Jan 1 00:03:49 (none) kernel: Cleanup /dev/hda9 pass 1
Jan 1 00:03:49 (none) kernel: ext2fs_check_if_mount: No such file or directory while determining whether /dev/hda9 is mounted.^M
Jan 1 00:03:49 (none) kernel: /dev/hda9 was not cleanly unmounted, check forced.
Jan 1 00:03:49 (none) kernel: Fix summary information? yes
Jan 1 00:03:49 (none) kernel:
Jan 1 00:03:49 (none) kernel: /dev/hda9: 1391/32768 files (1.2% non-contiguous), 17391/131072 blocks
Jan 1 00:03:49 (none) kernel: Cleanup /dev/hda9 pass 2
Jan 1 00:03:49 (none) kernel: ext2fs_check_if_mount: No such file or directory while determining whether /dev/hda9 is mounted.^M
Jan 1 00:03:49 (none) kernel: /dev/hda9: clean, 1391/32768 files, 17391/131072 blocks
Jan 1 00:03:49 (none) kernel: /dev/hda9 is clean after pass 2
Jan 1 00:03:49 (none) kernel: Mounting /var
Jan 1 00:03:49 (none) kernel: warning: can't open /var/mtab: No such file or directory
Jan 1 00:03:49 (none) kernel: /dev/hda9 on /var type ext2 (rw)
Jan 1 00:03:49 (none) kernel: Cleaning up /var/mtab...
Jan 1 00:03:49 (none) kernel: Using default TIVO_SVR_ADDR
Jan 1 00:03:49 (none) kernel: Mounting initial environment...
Jan 1 00:03:49 (none) kernel: Cleaning up temporary files in /var/tmp
Jan 1 00:03:49 (none) kernel: Cleaning up old slices and bundles in /var/packages...
Jan 1 00:03:49 (none) kernel: Checking space in /var
Jan 1 00:03:49 (none) kernel: About to check tasks for tty to shutdown
Jan 1 00:03:49 (none) kernel: This one's (29) goin' down
Jan 1 00:03:49 (none) kernel: Attempting to fix modem using: /tvlib/modem/patches/P2109-V90/ram/expect_script
Jan 1 00:03:49 (none) kernel: spawn /tvbin/modempatch /tvlib/modem/patches/P2109-V90/ram/Patch9-2-RAM.s37 ^M
Jan 1 00:03:49 (none) kernel: ATZ^M^M
Jan 1 00:03:49 (none) kernel: OK^M
Jan 1 00:03:49 (none) kernel: AT**^M^M
Jan 1 00:03:49 (none) kernel: Download initiated ..^M
Jan 1 00:03:49 (none) kernel: Getting ready to send files
Jan 1 00:03:49 (none) kernel: ..................................................^M
Jan 1 00:03:49 (none) kernel: OK^M
Jan 1 00:03:49 (none) kernel: Sending of patch succeeded
Jan 1 00:03:49 (none) kernel: INTERACTIVE
Jan 1 00:03:49 (none) kernel: ^MAT!9F01?^M^M
Jan 1 00:03:49 (none) kernel: 9F01: 09 02 A9 6B 8D E7 9D E2 ^M
Jan 1 00:03:49 (none) kernel: OK^M
Jan 1 00:03:49 (none) kernel: PATCH_VERIFIED
Jan 1 00:03:49 (none) kernel: FILEBASED
Jan 1 00:03:49 (none) kernel: EXITING WITH '0'
Jan 1 00:03:49 (none) kernel: About to check tasks for tty to shutdown
Jan 1 00:03:49 (none) kernel: Scanning for phase1 repair scripts
Jan 1 00:03:49 (none) kernel: Initializing TiVo extension...
Jan 1 00:03:49 (none) kernel: Set up environment vars for hardware configuration...
Jan 1 00:03:49 (none) kernel: Remote control is TIVO
Jan 1 00:03:49 (none) kernel: MFS partition on /dev/hda10
Jan 1 00:03:49 (none) kernel: Loading media drivers...
Jan 1 00:03:49 (none) kernel: Loading ideturbo ...
Jan 1 00:03:49 (none) kernel: ideturbo version mismatch, not enabling
Jan 1 00:03:49 (none) kernel: Auto-detecting oslink module (asic 1).
Jan 1 00:03:49 (none) kernel: Multi-Verifier
Jan 1 00:03:49 (none) kernel: Not Installing oslink module.
Jan 1 00:03:49 (none) kernel: Loading fan ...
Jan 1 00:03:49 (none) kernel: Loading therm ...
Jan 1 00:03:49 (none) kernel: Loading pxmpegdecode ...
Jan 1 00:03:49 (none) kernel: We are using the Philips 7128 video encoder.
Jan 1 00:03:49 (none) kernel: pxmpegdecode configured in PAL mode.
Jan 1 00:03:49 (none) kernel: PX DECODE HYBRID: IBM CS22 initialization completed!
Jan 1 00:03:49 (none) kernel: MPEG: MPEG subsystem initialization completed
Jan 1 00:03:49 (none) kernel: MAJOR number = 78
Jan 1 00:03:49 (none) kernel: Loading scartmux ...
Jan 1 00:03:49 (none) kernel: Splash the screen...
Jan 1 00:03:49 (none) kernel: Writing 401560 bytes to OSD at address 0
Jan 1 00:03:49 (none) kernel: cachecard: driver version 20050218
Jan 1 00:03:49 (none) kernel: cachecard: updated tlb entry 2 to 1M
Jan 1 00:03:49 (none) kernel: cachecard: found 1 chip groups
Jan 1 00:03:49 (none) kernel: cachecard: found 4 banks
Jan 1 00:03:49 (none) kernel: cachecard: found 8192 rows
Jan 1 00:03:49 (none) kernel: cachecard: found 2048 cols
Jan 1 00:03:49 (none) kernel: cachecard: memory found: 512 MB
Jan 1 00:03:49 (none) kernel: cachecard: csum table size = 4MB
Jan 1 00:03:49 (none) kernel: cachecard: sdram cache size = 508MB
Jan 1 00:03:49 (none) kernel: cachecard: mappable size = 1016MB
Jan 1 00:03:49 (none) kernel: cachecard: driver loaded successfully
Jan 1 00:03:49 (none) kernel: cachectl: Driver version: 20050218/20050218
Jan 1 00:03:49 (none) kernel: cachectl: 512MB DIMM detected
Jan 1 00:03:49 (none) kernel: cachectl: Found partition 0:10 (512MB)
Jan 1 00:03:49 (none) kernel: cachectl: Found partition 0:12 (0MB)
Jan 1 00:03:49 (none) kernel: cachectl: Found partition 0:14 (0MB)
Jan 1 00:03:49 (none) kernel: sys_readsectors: filp is NULL
Jan 1 00:03:49 (none) kernel: cachectl: 513MB database detected
Jan 1 00:03:49 (none) kernel: cachectl: Writing.... 0% .... 25% .... 50% .... 75% .... 100% cachectl:
Jan 1 00:03:49 (none) kernel: cachectl: Verifying... 0% .... 25% .... 50% .... 75% .... 100% cachectl:
Jan 1 00:03:49 (none) kernel: cachecard: zone[0] = 0:10 (512MB)
Jan 1 00:03:49 (none) kernel: cachecard: zone[1] = 0:12 (0MB)
Jan 1 00:03:49 (none) kernel: cachecard: zone[2] = 0:14 (0MB)
Jan 1 00:03:49 (none) kernel: cachectl: Caching.... 0% .... 25% .... 50% .... 75% .... 100% cachectl:
Jan 1 00:03:49 (none) kernel: Writing 401560 bytes to OSD at address 0
Jan 1 00:03:49 (none) kernel: Update IR microcode using /sbin/irmicro.hex
Jan 1 00:03:49 (none) kernel: Atmel part found, 2kB of program memory, AT90S2313
Jan 1 00:03:49 (none) kernel: MicroVeriry: bad=0, GetFpaRegCnt=0, AndFpgaCnt=0, OrFpgaCnt=0
Jan 1 00:03:49 (none) kernel: Device already programmed with this microcode
Jan 1 00:03:49 (none) kernel: Starting update ...
Jan 1 00:03:49 (none) kernel: Look for debug board ...
Jan 1 00:03:49 (none) kernel: SIOCSIFHWADDR: Operation not supported by device
Jan 1 00:03:49 (none) kernel: IP struct was not filled in!
Jan 1 00:03:49 (none) kernel: sa is: 0x20000 0x0 0x7ffffce4 0x7ffffd00
Jan 1 00:03:49 (none) kernel: sa.sin_addr = 0x7ffffc48 a sockaddr is 16 bytes
Jan 1 00:03:49 (none) kernel: SIOCSIFADDR: Operation not supported by device
Jan 1 00:03:49 (none) kernel: eth0: unknown interface.
Jan 1 00:03:49 (none) kernel: Setting TCP keepalive parameters...
Jan 1 00:03:49 (none) kernel: Starting logging daemons...
Jan 1 00:03:49 (none) kernel: Check for PROM update ...
Jan 1 00:03:49 (none) kernel: Loading mixaud ...
Jan 1 00:03:49 (none) kernel: Updating system clock UID=0
Dec 16 18:46:16 (none) kernel: Time set to: Fri Dec 16 18:46:16 2005
Dec 16 18:46:16 (none) kernel: Have a nice day.
Dec 16 18:46:16 (none) kernel: Checking for additional disk...
Dec 16 18:46:16 (none) kernel: Starting EventSwitcher...
Dec 16 18:46:18 (none) kernel: Start fan control...
Dec 16 18:46:19 (none) kernel: Scanning for phase2 repair scripts
Dec 16 18:46:21 (none) kernel: Checking for database conversions...
Dec 16 18:46:22 (none) kernel: Checking new software installation
Dec 16 18:46:22 (none) kernel: SwSystem 2.5.5-01-1-023 is already active, nothing to do.
Dec 16 18:46:22 (none) kernel: Scanning for phase3 repair scripts
Dec 16 18:46:22 (none) kernel: Starting Services.
Dec 16 18:46:23 (none) kernel: Scanning for phase4 repair scripts
Dec 16 18:46:23 (none) kernel: rc.sysinit is complete
Dec 16 18:46:23 (none) kernel: turbonet2: driver version 20050218
Dec 16 18:46:23 (none) kernel: turbonet2: using MAC address 00:0B:AD:CF:A1:81
Dec 16 18:46:23 (none) kernel: turbonet2: driver successfully installed
Dec 16 18:46:23 (none) kernel: turbonet2: driver successfully installed
Dec 16 18:46:23 (none) kernel: IP struct was not filled in!
Dec 16 18:46:23 (none) kernel: MCP startup complete
Dec 16 18:46:24 (none) kernel: sa is: 0x20000 0xc0a801d2 0x7ffffcd4 0x7ffffcf0
Dec 16 18:46:24 (none) kernel: sa.sin_addr = 0x7ffffc38 a sockaddr is 16 bytes
Dec 16 18:46:25 (none) kernel: Couldn't bind to socket.
Dec 16 18:46:27 (none) kernel: turbonet2: link = 100Mbps full-duplex
Dec 16 18:46:30 (none) kernel: EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
Dec 16 18:46:42 (none) kernel: Microcode version 00034
Dec 16 18:46:43 (none) kernel: setup: 0x00000000
Dec 16 18:46:43 (none) kernel: shutdown
Dec 16 18:46:43 (none) kernel: Initialize with 1 live caches
Dec 16 18:46:43 (none) kernel: mediaswitch: resetting adjustments
Dec 16 18:46:43 (none) kernel: tivoblaster.C::ReadTivoFormatKey(), Line : 356, Found 350 ms. Prefix.
Dec 16 18:46:43 (none) kernel: osd buffer size = 1080000
Dec 16 18:46:48 (none) kernel: mediaswitch: returning -1 from standin tune after tuning to ch -3 with adjust 0
Dec 16 18:46:48 (none) kernel: tuning:lock 1
Dec 16 18:46:49 (none) kernel: Done with this packet
Dec 16 18:47:58 (none) kernel: tcp_keepalive: call keepopen(0x80e4b5e0)
Dec 16 18:47:59 (none) kernel: tcp_keepalive: call keepopen(0x80e4b300)
Dec 16 18:47:59 (none) kernel: tcp_keepalive: call keepopen(0x80e4b020)
Dec 16 18:47:59 (none) kernel: tcp_keepalive: call keepopen(0x802c3320)

I have 300 Mb Swap file, Cachecard with 512Mb and various hacks.

Is it possible the image is corrupted?

I suppose next steps are:

Install HD from another (working) TiVo
Swap Cachecard for another
Try running Cachecard with no memory
Double check no other IR devices are around.

Any other suggestions gratefully received.


Edit: test and daily calls are failing - 'unknown error'

__________________
TiVo 200Gb, Mode 0 VBR, SDI output, Lumagen HDP Pro scaler, Pioneer 50MXE-1 Plasma, Arcam FMJ AV8/P7, Martin-Logan ELS, Velodyne DD15 sub.

Last edited by Heuer : 12-16-2005 at 02:09 PM.
Heuer is offline Report Bad Post Report Post
Old 12-16-2005, 04:36 PM   #2 (Print)
blindlemon
tivoheaven.co.uk
 
Join Date: May 2002
Location: Malmesbury, UK
Posts: 3,200
Invalid swap partition:-
Quote:
Jan 1 00:03:49 (none) kernel: Activating swap partitions
Jan 1 00:03:49 (none) kernel: Unable to find swap-space signature
Jan 1 00:03:49 (none) kernel: swapon: /dev/hda8: Invalid argument
Which version of the LBA48 CD are you using?

At least one of the later ones has the byteswapping round the wrong way. I always use the Version 1.0 ISO

__________________
6023, Lifetime, 240gb (Samsung) Sky, CacheCard, Mode 0, 100+ SPs/AWLs
6022, Lifetime, 160gb (Seagate), Freeview, Turbonet, Mode 0, 90+ SPs/AWLs
601E, Lifetime, ... my 'test' machine!
blindlemon is offline Report Bad Post Report Post
Old 12-16-2005, 05:06 PM   #3 (Print)
Heuer
Registered User
 
Join Date: Mar 2004
Location: Nottinghamshire
Posts: 270
PTV LBA48-4.01

I will try your suggestion. This is the only SDI modified TiVo in the world so I would hate to see it consigned to the great hardware scrapyard in the sky!

Thanks Blindlemon .

Edit: I used the same disk to do the backups so does this mean they are trashed or is it only the restore that will be affected?

__________________
TiVo 200Gb, Mode 0 VBR, SDI output, Lumagen HDP Pro scaler, Pioneer 50MXE-1 Plasma, Arcam FMJ AV8/P7, Martin-Logan ELS, Velodyne DD15 sub.

Last edited by Heuer : 12-17-2005 at 03:19 AM.
Heuer is offline Report Bad Post Report Post
Old 12-17-2005, 06:59 AM   #4 (Print)
Glesgie
Registered User
 
Join Date: Feb 2003
Location: London
Posts: 194
Had the exact same symptoms when I did a mfsbackup mfsrestore to a 250GB disk
from an LBA48 160GB disk.

Redid copykern on it and all fine now.
Glesgie is offline Report Bad Post Report Post
Old 12-17-2005, 07:29 AM   #5 (Print)
blindlemon
tivoheaven.co.uk
 
Join Date: May 2002
Location: Malmesbury, UK
Posts: 3,200
If you used the 4.01 CD your backup should be OK as it was only the 4.0 CD that was byteswapped - and mfsbackup does its own byteswapping anyway.

I will check out the 4.01 CD myself when I get a chance, but my recommendation would be to re-run copykern from the Version 1.0 CD I linked to as a first step.

Edit: just checked the 4.01 CD and it fails to properly mount at /cdrom without intervention on my 'upgrades' PC. This causes copykern to fail to copy the LBA48 kernel or initialise the swap. Running the command /mount /dev/hdX /cdrom before running copykern seems to fix it, but I for one won't be "upgrading'' to this CD

__________________
6023, Lifetime, 240gb (Samsung) Sky, CacheCard, Mode 0, 100+ SPs/AWLs
6022, Lifetime, 160gb (Seagate), Freeview, Turbonet, Mode 0, 90+ SPs/AWLs
601E, Lifetime, ... my 'test' machine!

Last edited by blindlemon : 12-17-2005 at 08:08 AM.
blindlemon is offline Report Bad Post Report Post
Old 12-17-2005, 02:34 PM   #6 (Print)
Heuer
Registered User
 
Join Date: Mar 2004
Location: Nottinghamshire
Posts: 270
Although I can restore from the 1.0 disk I cannot seem to find the Copykern command. When I boot with the disk I do not get the PTV Q&A list as suggested in the readme.txt. Seems it is not finding my CD-Rom drive and not mounting.

I have source HD as hda, TiVo disk as hdb and the CD as hdc (secondary master). Can I run copykern from the CD and if so which folder is it in?

__________________
TiVo 200Gb, Mode 0 VBR, SDI output, Lumagen HDP Pro scaler, Pioneer 50MXE-1 Plasma, Arcam FMJ AV8/P7, Martin-Logan ELS, Velodyne DD15 sub.
Heuer is offline Report Bad Post Report Post
Old 12-17-2005, 04:45 PM   #7 (Print)
blindlemon
tivoheaven.co.uk
 
Join Date: May 2002
Location: Malmesbury, UK
Posts: 3,200
Try

mount /dev/hdc /cdrom

before running copykern.

__________________
6023, Lifetime, 240gb (Samsung) Sky, CacheCard, Mode 0, 100+ SPs/AWLs
6022, Lifetime, 160gb (Seagate), Freeview, Turbonet, Mode 0, 90+ SPs/AWLs
601E, Lifetime, ... my 'test' machine!
blindlemon is offline Report Bad Post Report Post
Old 12-18-2005, 10:08 AM   #8 (Print)
Heuer
Registered User
 
Join Date: Mar 2004
Location: Nottinghamshire
Posts: 270
Brilliant! Worked perfectly that time and TiVo SDI is off and running.

Many thanks Blindlemon and if I ever need a large pre-formatted TiVo HD you will be my first stop. Your reputation in these matters is well deserved.

__________________
TiVo 200Gb, Mode 0 VBR, SDI output, Lumagen HDP Pro scaler, Pioneer 50MXE-1 Plasma, Arcam FMJ AV8/P7, Martin-Logan ELS, Velodyne DD15 sub.
Heuer is offline Report Bad Post Report Post
 
Forum Jump
Thread Tools

Go Back  TiVo Community Archive2 > Main TiVo Forums > TiVo UK

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:25 AM.


Powered by: vBulletin Version 3.0.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
(C)opyright - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not affiliated with TiVo Inc.


Spider History Index